华为交换机配置 DHCP Snooping 解决 DHCP 冲突问题

实验背景

公司内部有员工将无线路由器接入到网络中,并非法启用了 DHCP 服务,导致其他用户获取到了错误的 IP 地址无法上网。管理员需要开启 DHCP Snooping 功能,保证 DHCP 客户端从合法的 DHCP 服务器获取 IP 地址。

实验拓扑

SW1 作为核心交换机,在交换机上配置 DHCP 服务器。SW2 作为接入交换机,在交换机全局使能 DHCP Snooping,并将上联端口配置为信任接口,两台 PC 终端的端口上使能 DHCP Snooping 功能。配置完成后接入交换机只会将 PC 的 DHCP 请求报文通过信任接口发送给核心交换机。

华为交换机配置 DHCP Snooping 解决 DHCP 冲突问题

操作步骤

1、进入 SW1 交换机,配置 DHCP 服务器。

<SW1>system-view
[SW1]vlan batch 12
[SW1]dhcp enable

[SW1]interface Vlanif 12
[SW1-Vlanif12]ip address 192.168.12.1 255.255.255.0
[SW1-Vlanif12]dhcp select interface

[SW1]interface GigabitEthernet 0/0/1
[SW1-GigabitEthernet0/0/1]port link-type trunk
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 12

2、进入 SW2 交换机,配置 DHCP Snooping 功能。

<SW2>system-view
[SW2]vlan batch 12
[SW2]dhcp enable
# 全局使能 DHCP Snooping 功能,并仅处理 DHCPv4 报文
[SW2]dhcp snooping enable ipv4

# 配置上联端口为信任接口,使交换机只处理该端口收到的 DHCP 响应报文
[SW2]interface GigabitEthernet 0/0/48
[SW2-GigabitEthernet0/0/48]port link-type trunk
[SW2-GigabitEthernet0/0/48]port trunk allow-pass vlan 12
[SW2-GigabitEthernet0/0/48]dhcp snooping trusted

# 使能用户侧端口的 DHCP Snooping 功能
[SW2]interface range GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2
[SW2-port-group]port link-type access
[SW2-port-group]port default vlan 12
[SW2-port-group]dhcp snooping enable

3、验证配置。

[SW2]display dhcp snooping configuration 
#
dhcp snooping enable ipv4
#
interface GigabitEthernet0/0/1
 dhcp snooping enable
#
interface GigabitEthernet0/0/2
 dhcp snooping enable
#
interface GigabitEthernet0/0/48
dhcp snooping trusted
#
本文为原创文章,著作权归作者所有:来自「KOBIN 技术随笔」作者的原创作品,转载请标明出处。
华为交换机配置 DHCP Snooping 解决 DHCP 冲突问题
https://blog.kobin.cn/blog/network/n3/2391.html
(3)

相关文章

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注

CAPTCHAis initialing...